
Bindings Example Exercise
James Dempsey - WWDC Pre-Show Cocoa Workshop

In this exercise you will create a basic document-based application using Cocoa 
Bindings.  This application will allow the user to create a list of records, each record 
consisting of a string, a boolean flag, a date, and a number.  The application will allow for 
saving changes to the document, and opening saved documents.

Creating the Project

1. Launch Xcode

2. Use File > New Project… to create a project of type Cocoa Document-based 
Application.

3. Name the project BindingExample and save it wherever you wish in within your 
home folder.
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The Model

This is a document-based application.  The data model is very simple – an array filled 
with mutable dictionaries.  Each dictionary will contain four possible keys “string”, 
“number” “date” and “flag”.

The diagram below represents an example object graph of this application’s model.

Using a property list

Typically, when you create custom classes as your application’s data model, you use 
NSArchiver and NSUnarchiver to serialize classes.

Because this application is using generic containers such as dictionaries and arrays, as 
well as simple properties such as strings, dates, and numbers, this application can 
serialize these objects into the property list format.  This is the format used for many 
things in Mac OS X such as preference files, Info.plist files within Xcode projects, and in 
various other places throughout the system.
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Adding Persistence

Before laying out the user interface, and binding it to the application’s data model – take 
the time to set up the application for persistence.

To add the ability to save and open documents in this exercise, you will make the 
following changes to MyDocument.h and MyDocument.m:

Add an instance variable and accessor methods to hold the array.
Add code for memory management of the array.
Add code to serialize/deserialize as a property list.

In addition, you will setting the document extension in the application project.

Add a declaration for the NSArray and accessor methods to MyDocument.h – the 
changes are in bold.

 @interface MyDocument : NSDocument
{
             NSArray    *records;
}

- (void) setRecords:(NSArray *)records;
- (NSArray *)records;

In MyDocument.m add the following code to handle the serialization / deserialization of 
the  property list, as well as accessors and memory management for handling the records 
array.  Changes from the default MyDocument.m file are in bold.

@implementation MyDocument

- (id)init
{
    self = [super init];
    if (self) {
        records = [[NSArray alloc] init];
    }
    return self;
}

- (void)dealloc
{
    [records release];
    [super dealloc];
}

- (NSString *)windowNibName
{
    return @"MyDocument";
}
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- (void)windowControllerDidLoadNib:(NSWindowController *)aController
{
    [super windowControllerDidLoadNib:aController];

}

/* The model of this application is simply an array of dictionaries.  
   These are stored on disk in property list format.
   The extension of files for this application is .demo.
*/
- (NSData *)dataRepresentationOfType:(NSString *)aType
{

    NSString *error;

    return [NSPropertyListSerialization 
   dataFromPropertyList: [self records]
                        format: NSPropertyListXMLFormat_v1_0
              errorDescription: &error];
}

- (BOOL)loadDataRepresentation:(NSData *)data ofType:(NSString *)aType
{
    // Read in the data with all Mutable containers
    NSString *error;

    [self setRecords:[NSPropertyListSerialization 
    propertyListFromData: data
   mutabilityOption: NSPropertyListMutableContainers
      format: NULL
   errorDescription: &error]];

    return YES;
}

// Accessor Methods
- (void) setRecords:(NSArray *)newValue
{
    if (newValue != records) {
        [records release];
        records = [newValue copy];
    }
}

- (NSArray *)records
{
    return records;
}

@end
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Setting the Document Type

To set the document extension of the application to .demo you need to edit the properties 
of the application target in Xcode.

To do this select the BindingExample target within the Targets group in your project.  (If 
you choose another name for the project, choose that name instead).

Then select Project > Get Info  (Command-I)

In the target info inspector, select the Properties tab.

In the Identifier section towards the top type a unique identifier for your application.  The 
example application uses ‘com.demo.BindingExample’

In the Document Types table at the bottom of the window, edit the Extensions field of the 
first row so that it contains the extension ‘demo’.  Do not enter a dot before demo, or 
quotation marks.
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Checkpoint – Build and Test:

Before you go on to setting up user interface and bindings, you can compile and run the 
application, just to ensure you haven’t missed any of the steps thus far.

When you launch the application, you should get an untitled document window.

You can test what you have so far by saving, closing, and reopening the document.  

Since the document is in property list format, you should be able to open it in the 
Property List Editor utility (located in /Developer/Applications/Utilities).  The saved 
document should contain a single, empty array as its root object.
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The View and bindings  (Onto the fun stuff)

First, add the ability to view and edit the list of records in a table view.  

Getting the table view ready
Set up a table view in the document window with four columns; edit the column headers 
of each column to read “Flag”, “String”, “Number’ and “Date”.

Then add three buttons below the table labeled “Insert”, “Add”, and “Remove”.

The document window should look similar to the image below:
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Adding formatters and custom cells.

Custom cells
The ‘flag’ column should contain checkboxes.

In the Data palette in Interface Builder, drag the checkbox cell to the Flag table header in 
your table.

This will set that table view column to use a checkbox.

Formatters
The number column should have a number formatter associated with it, and the Date 
column should have a date formatter.

Switch to the Text palette and drag a number formatter to the Number column, and a date 
formatter to the Date column.

The default values for the number and date formatters are fine for this exercise.
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Adding an NSArrayController

Using the Controllers palette in Interface Builder, drag an NSArrayController – the 
rightmost of the three items – to the MyDocument nib file.

 

After doing so, the MyDocument nib file window should look similar to this:
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Inspecting the NSArrayController

Select the array controller in the nib file, and show its Attribute info (Command-1).  
Notice the Object Class Name field – this tells the array controller what sort of objects are 
contained inside of the array that it controls.  The default is NSMutableDictionary – in 
this exercise that is the correct class.

You also have the ability to edit a list of keys.  These keys will automatically be made 
available to you in the Interface Builder interface whenever you make connections to this 
controller.
Add the keys “string”, “date”, “flag”, “number”.  Note that these keys exactly match the 
names of the keys we plan to store.
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Binding the table view columns

Select the Flag column and view its info.  
Select Bindings info from the popup.  
Click on the value binding to show the details of that binding.  
What you see should look like the following:
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Note that the Bind to popup has the array controller pre-selected.  In addition the 
Controller Key already has arrangedObjects selected.

From the Model Key Path: popup select “flag”.  When you do so, the window should 
look like the following:
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Repeat the last two steps to bind the value attribute of the remaining three table columns.
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Setting up the buttons 

When you write your own controller classes, you usually write action methods within 
those controller classes.  Similarly, the array controller has pre-defined actions for adding, 
inserting, and removing items from an array.

You use standard, traditional Cocoa target action to set this up.

From the Insert button, control-drag to the array controller.

Set the action to be insert:

Repeat for the Add and Remove buttons, control-dragging to the array controller, and 
setting the actions to add: and remove:, respectively.
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Checkpoint – Test Interface in Interface Builder:
You have now gone through the steps of binding the table view to the array controller.  
Test the interface by selecting File > Test Interface (Command-R).

Things to test:
You should be able to use the Insert and Add buttons to add new items to the table

You should be able to edit each column.

You should be able to use the Remove button to remove an item from the table

You should be able to click on the table headers to sort the selected column header.
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Binding the Array Controller to the document’s array

The table view columns are now bound to the array controller.  There is one more basic 
task required – the array controller needs to know where it is getting the array that it will 
be operating on.

Since this is a document-based application, the File’s Owner of the document’s nib file is 
our subclass of NSDocument, MyDocument.

In addition to being able to bind an object to a controller object, you can also bind 
directly to a nib’s File’s Owner.

To bind the array controller’s contents to the records array stored within the 
MyDocument class (the nib’s File’s Owner).

Select the NSArrayController and show the Binidngs info panel (Command-4)
Open the contentArray binding
Select File’s Owner from the Bind to: popup
In the Model Key Path: combo box, type records.
(‘records’ is the key of the property that stores the array of records)
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Checkpoint – Build and Test

Save the changes to the nib file.  You should now be able to build and run the application.

Test the following things:

You should be able to insert/add new records and edit them in the table view.
You should be able to delete records.
You should be able to save changes to a file, then reopen the file.

If you are curious, open the saved file in Property List Editor to see it represented as a 
plist.

Additional Enhancements

1.  Display and edit selected record
Try adding controls to inspect the currently selected item in the table view.
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To do this, bind the value of each control to the appropriate model key of the array 
controller’s selection.  For example: 

2. Multiple Selections
Inspect the table view, and view the Attributes info (Command-1).  Allow multiple 
selections by checking the Multiple Selections checkbox.

When you run the application, you should now be able to select multiple items in the 
table view.

If you implemented optional enhancement #1 you will notice that the field that display 
the value of the selection update appropriately and automatically to handle multiple 
selected items.  If the value of all selected items is the same, the value is displayed.  If the 
value is different, a placeholder indicates that multiple values are selected (or the mixed 
state in the case of a checkbox).  Editing the value updates all selected items. 

3. Enable and Disable Buttons
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In addition to keeping track of the list of arranged objects, and the selection, the array 
controller has a number of other keys, including ‘canInsert’, ‘canAdd’, and ‘canRemove’.  
These return a boolean based on the selection state of the array controller.

Bind the enabled attribute of each button to the appropriate array controller key.  For 
example:

Note that since the binding is interested only in a property of the array controller, and not 
a property in the model object, that the Model Key Path is left blank.

4. Display Total Number Displayed and Selected
Next you’ll use the ‘displayPatternValue’ bindings of a label text field to display the 
count of items displayed, and the count of selected items.  (For example “3 of 23 
selected”)

The displayPatternValue binding dynamically performs variable substitution on a display 
string.  In this exercise the string we will use is:

 %{value1}@ of %{value2}@ selected

Add a Small System Font Text Field from the Text palette in Interface Builder, and 
position it at the bottom of the table view.
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Select the text field and disclose the displayPatternValue1 binding, and configure it to 
appear as follows:

The count of the selection of the array controller will be calculated, and substituted for 
the string %{value1}@ in the display pattern.  More on the @count key in a moment.

Notice that a new binding ‘displayPatternValue2’ has appeared.  The value of this binding 
will be substituted for the string %{value2}@ in the display pattern string.

Set the displayPatternValue2 binding to appear as follows:

A display pattern value is very handy for combining a number of values into a single 
display string, as is the case here.
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In addition to the display pattern value, the array operator @count is used.

There are a number of different special keys that an array responds to.  One of the most 
commonly used is '@count', which returns the number of items in that array.

5. Other array operators
There are number of aggregate keys in addition to @count, including @sum and @avg.

To try these two aggregates out add two text labels and bind them:

First text field:

Second Text Field:

 
Feel free to try @min and @max as well.

Read more about the full set of array operators in the documentation at:

http://developer.apple.com/documentation/Cocoa/Conceptual/KeyValueCoding/
index.html
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6. Saving preferences with NSUserDefaultsController and using a value transformer
For this enhancement, you will add a color well.  The user will be able to change the 
color of the text in the ‘String:” text field.  This color value will be saved as a preference 
using the NSUserDefaultsController.

Add a color well so the window now looks similar to this:

The user defaults controller binds values to the application's shared user defaults.

There are two way to get a user defaults controller.  You can explicitly drag one from the 
controller palette into your nib file, or one will be added automatically the first time you 
choose "Shared User Defaults" as the controller in a binding.
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The Instances tab of your nib file should look similar to this, once you have used a 
defaults controller for the first time in the nib:

In this example, there are two relevant bindings.   The value binding of the NSColorWell 
is set to a particular key 'stringColor' in the Shared User Defaults controller.  Then, the 
textColor binding of the first NSTextField is bound to the same key in the Shared User 
Defaults controller.  The choice of the key name 'stringColor' is arbitrary, any key name 
could be used.

Set the color well’s value binding as follows:

Shared User Defaults is available from the popup.  Type in ‘stringColor’ as the Model 
Key Path.  Be sure to select NSUnarchiveFromData from the Value Transformer combo 
box.
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Select the String text field and set its textColor binding in exactly the same manner: 

NOTE: Be sure to bind to the textColor binding

If you run the application now, you should be able to change the color and have the string 
field’s color update immediately.  If you quit and restart the application, the color value 
you selected should persist between application launches.

Value Transformers
In both bindings, you used the NSUnarchiveFromData value transformer.  A value 
transformer is an object that takes a value in one form, and transforms it into something 
different.  Value transformers often come in handy when the way something is stored in 
the model is not exactly in the form you need in the view.

A default color is a good example of this.  The color well and text field both need an 
NSColor object, however, to store the NSColor object as a user default, the color object 
must be archived and stored as an NSData, then unarchived when retrieved from user 
defaults.  The NSUnarchiveFromData value transformer automatically archives and 
unarchives the NSColor.

Other built in transformers are:

NSNegateBooleanTransformer - turns a true into false and vice versa.  Handy when the 
value you are storing is the opposite to the value you need for a binding.

NSIsNilTransformer
NSIsNotNilTransformer - allow you to return a boolean based on whether a value is nil 
or not.  Can be very useful, especially for bindings like enabled or hidden.

You can also write your own value transformers, which are subclasses of 
NSValueTransformer.
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