Installing Ruby on Rails

The programming projects for this class require you to use Ruby 1.9.2 and Rails 3.2.1. If you don't already have these packages installed on your laptop, follow the instructions below to install them. Note: these instructions are for Ruby 1.9.2, but we believe version 1.9.3 will work equally well, and some of the installers will install 1.9.3 by default. The installation process is different depending on whether you are running Windows, MacOS, or Linux:


Mac OS X


We don't officially support Linux for this class, so you will be mostly on your own if you want to use it. However, we think the following instructions may work: