Stanford Web Forms Service Issues

From Web Services Wiki

Revision as of 15:54, 7 October 2010 by Mrmarco (Talk | contribs)
(diff) ←Older revision | Current revision (diff) | Newer revision→ (diff)
Jump to: navigation, search

This page contains all known current issues with the Stanford Web Forms Service and a list of resolved issues for reference.

Contents

Open Bugs

Form Management

Form Building

Build

Edit

  • Deleting the last question in a survey causes an error

Publish

Form Rendering

Form Validation

  • The new HTML5 email input field is not handled correctly by Chrome. Chrome performs the validation, but does not display any UI to show the user something has failed. It simply stops the user from submitting the form. It should be possible to use the :invalid selector to give the user some feedback, even if it's not as detailed as the one given by the forms service after submission.

Data Viewer

Resolved Bugs

  • Trying to add a form to "My Forms" when the URL didn't exist would return a not very useful, generic error.
  • The number of entries is not updated when you delete them through the data viewer
  • If you hit Refresh/Reload in the browser after deleting a field, the builder will attempt to delete that field again. If there is no field at that position, it will throw an error. If there is, it will delete the next field.
  • Quotes and HTML tags break the rendering in the edit/publish tabs. For example, everything typed after a " is not shown.
  • If you create a form, place it into a location, and then delete it again, that location is no longer available for a new form.
  • If there is at least one required asterisk, a legend should be shown, but isn't.
  • The creation date updates when someone submits the form and it's saved to the database.
  • The form viewer shows ID's as the first column, but these can be confusing as they only show odd numbered IDs (this is due to the MySQL server being replicated - Added FAQ
  • Create new form should really be a button, not a link, so reloading/refreshing the browser doesn't start a new form.
  • Entries list doesn't update (because you can't submit data just yet)
  • Creation Date should really show latest on top
  • Buttons to add fields should really be buttons rather than links, so reloading/refreshing the browser doesn't add a duplicate field
  • Edit should complain if the label is left blank
  • Setting something to required should add some kind of indication that it is required on the preview pane (red asterisk?)
  • Editing options for selects, radio and checkboxes has a lot of icons. Considering limiting the functionality to make it simpler
  • Edit should complain if option labels are left blank
  • Need confirmation message when field properties have been set successfully
  • The icons (and alt/title mouseover text) are not consistent with the up/down/edit/delete links on the preview section
  • Builder should complain if you select "Show Message" but the message is blank
  • Builder should complain if you select "Redirect to Web Page" but the URL is blank, or not a well formed URL
  • Builder should complain if you select to send email but left the email blank, or used an incorrectly formatted email
  • Builder should complain if you try to make a form live, but don't provide an AFS path
  • Need a page, note or something to explain the whole AFS path thing (why you need to add an AFS path even though the form doesn't get written there)
  • Headings in form preview are not consistent in style (some are black, e.g. radio buttons, others are gray, e.g. check boxes)
  • Need to make sure the asterisk (for required fields) is used in an accessible way
  • Help text throughout needs editing
Personal tools