Theano

From FarmShare

(Difference between revisions)
Jump to: navigation, search
(Created page with "Alex test install Theano 0.8.2 (non-GPU) on Python 3.x on my local Ubuntu 15.10 machine. Needs packages: libatlas-base-dev python3-scipy python3-numpy python3.4-dev py...")
Line 16: Line 16:
...errors out on something about numpy/scipy problem...
...errors out on something about numpy/scipy problem...
 +
 +
Let's try again without a virtualenv, so hopefully we pick up the OS install of scipy/numpy:
 +
 +
  sudo aptitude install python3-pip
 +
  python3 -m pip install --user Theano
 +
 +
same errors?

Revision as of 14:31, 22 April 2016

Alex test install Theano 0.8.2 (non-GPU) on Python 3.x on my local Ubuntu 15.10 machine.

Needs packages:

 libatlas-base-dev
 python3-scipy
 python3-numpy
 python3.4-dev
 python3.4-venv

Now start up an new Python 3 virtualenv, call it 'env1'.

 python3 -m venv env1
 source env1/bin/activate #activate your venv
 which pip #check your pip is from your venv
 pip install --user Theano

...errors out on something about numpy/scipy problem...

Let's try again without a virtualenv, so hopefully we pick up the OS install of scipy/numpy:

 sudo aptitude install python3-pip
 python3 -m pip install --user Theano

same errors?

Personal tools
Toolbox
LANGUAGES