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Manipulating Images using Photoshop 

Photoshop is a software application used extensively by web designers and 
graphic artists to develop and manipulate images. 

In this class, only the main features of Photoshop will be covered. 

Obtaining Information about an Image 

When an image is viewed in Photoshop, the program offers information about the 
amount of disk space the image uses.  
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By default, Photoshop uses inches to describe the size of an image.  On the Web, 
however, pixels are used.  To configure Photoshop to use pixels, select the  
Units & Rulers preference (on the Edit menu, point to Preferences, and click 
Units & Rulers) and change the Rulers field to pixels: 

                      

      

In image editing programs, the canvas is the work space around and including 
the image.  Photoshop’s Canvas Size window provides information about the size 
of the graphic’s canvas and allows the graphic designer to change it.  To change 
or view the canvas size, on the Image menu, click Canvas Size: 
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The Image Size window provides information about the size of the image (and 
its canvas).  It also allows the graphic designer to change the height and width 
of the image.   
 
To view or change the image size, on the Image menu, click Image Size: 

          
 
The Info window provides detailed color information about each pixel in the 
graphic.   
 
To view the Info window, on the Window menu, click Info. 
 
Placing the cursor at a specific spot on a graphic will display the color (in RGB 
code – Red Green Blue) for that spot.  In the example below, at location 
9.222x3.819, the color is 216,94,91. 
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Cropping an Image 

Cropping an image allows you to discard portions of an image.   

To crop an image: 

1. Select the Rectangular Marquee Tool. 

 

2. Draw a box around the area to be cropped. 

 

3. On the Image menu, click Crop.  The new dimensions for the image will 
be displayed in the Info window. 
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Changing an Image’s Size 
In Photoshop CS3, you can change the size of an image (e.g., if you want to create 
a thumbnail version of an image for the Web). 
 
To change the size of an image: 

1. On the Image menu, click Image Size. 

2. Enter the new height/width desired, and click OK to finalize the change 
of size. 

          

 
Keep this chart in mind when choosing an image size: 
Monitor Resolution * Maximum Size of Material  (Width x Height) 

Web TV (TV set) 544 x 738 

640 x 480 600 x 300 

800 x 600 760 x 420 

1024 x 768 955 x 600 
* Monitor Resolution can be set at: 
   - Windows: Start > Settings > Control Panel > Display > Settings  
  - Mac OS X: System Preferences > Displays > Display  

Note: If you add a graphic to your web page before changing its size, you will 
need to change the height and width attributes in the source code.   
In Dreamweaver, this is done by clicking the Reset Image to Original Size icon   
in Properties.  
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Rotating an Entire Image by Rotating Its Canvas 

To rotate an entire image in Photoshop, rotate its canvas: 

1. Open the image you wish to rotate in Photoshop. 

2. On the Image menu, point to Rotate Canvas, and then click the 
transformation desired. 

         

 

Transforming (Including Rotating) Just a Portion of an Image 

To transform just a portion of an image: 

1. Open the image you wish to work on in Photoshop. 

2. Select the region you wish to transform. 

3. On the Edit menu, point to Transform, and then click the transformation 
desired. 
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Adjusting the Color of an Image 

To adjust the color of an image, on the Image menu, point to Adjustments, and 
select the adjustment desired. 

 
 

                      
 

Before (left) and after (right) using the Invert adjustment;  
the image’s colors are inverted – positive images become negative;  

negatives become positive images. 
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Filters 
Filters let you change the look of your images.  They can make images appear 
like impressionistic paintings or mosaic tiles; they can add unique lighting or 
create distortions. You can also use filters to clean up or retouch your photos. 
The filters provided by Adobe are listed in the Filter menu. Additional filters are 
available as plug-ins from third-party developers. Once installed, the names of 
these plug-in filters appear at the bottom of the Filter menu.  

To use a filter, choose the appropriate command from the Filter menu.  These 
guidelines can help you in choosing filters: 

• Filters are applied to the active, visible layer or the area you have selected. 

• For 8-bits images, most filters can be applied cumulatively through the 
Filter Gallery (on the Filter menu, click Filter Gallery). All filters can be 
applied individually. 

• Filters cannot be applied to Bitmap-mode or indexed-color images. 

• Some filters work only on RGB images. 

• All filters can be applied to 8-bit images.  

• The following filters can be applied to 16-bit images: Liquify, Average 
Blur, Bilateral Blur, Blur, Blur More, Box Blur, Gaussian Blur, Lens Blur, 
Motion Blur, Radial Blur, Sampled Blur, Lens Correction, Add Noise, 
Despeckle, Dust & Scratches, Median, Reduce Noise, Fibers, Lens Flare, 
Sharpen, Sharpen Edges, Sharpen More, Smart Sharpen, Unsharp Mask, 
Emboss, Find Edges, Solarize, De-Interlace, NTSC Colors, Custom, High 
Pass, Maximum, Minimum, and Offset. 

• The following filters can be applied to 32-bit images: Average Blur, 
Bilateral Blur, Box Blur, Gaussian Blur, Motion Blur, Radial Blur, Sampled 
Blur, Add Noise, Fibers, Lens Flare, Smart Sharpen, Unsharp Mask, De-
Interlace, NTSC Colors, High Pass, and Offset. 

• Some filters are processed entirely in RAM. If your entire available RAM 
is used to process a filter effect, you may get an error message. 

 
Before (left) and after (right) using the Lens Blur filter; 
 the background is blurred but foreground stays sharp 
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The Drawing Tools 
The drawing tools are used to draw shapes and objects on an image.   
To use a drawing tool in Photoshop: 

1. Select one of the drawing tools: 

• Brush. To paint brush strokes in a bitmap graphic. 

• Pencil. To draw 1-pixel-wide lines or to edit single pixels.  This tool is 
accessed by clicking the mouse button on the Brush Tool and selecting 
the Pencil Tool (Brush > Pencil Tool). 

• Pen. To draw by placing points that define a path. 

• Freeform Pen. To paint paths in a vector graphic.  This tool is accessed 
by clicking the mouse button on the Pen tool and selecting the 
Freeform Pen Tool (Pen > Freeform Pen Tool). 

• Rectangle. To draw rectangles. 

• Rounded Rectangle. To draw rectangles with rounded corners.  This 
tool is accessed by clicking the mouse button on the Rectangle tool and 
selecting the Rounded Rectangle Tool (Rectangle > Rounded 
Rectangle Tool). 

• Elipse. To draw circles and other elipses (Rectangle > Elipse Tool). 

• Polygon. To draw multi-sided objects.  To select the number of sides, 
select the Polygon Tool.  Then, in the toolbar, in the Sides field, enter 
the number of sides desired (Rectangle > Polygon Tool). 

• Line. To draw straight lines (Rectangle > Line Tool). 

• Custom Shape. To draw one of these custom shapes 
(Rectangle > Custom Shape). 

2. After selecting a tool, on the properties bar for the tool (located in the 
toolbar region), select the color, size, and style of the drawing tool as 
appropriate. 

3. Draw by clicking and dragging the mouse.  The example below shows a 
frame drawn using the Line Tool. 
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Using the Paint Bucket 

The Paint Bucket Tool is used to change the color of a region in Photoshop.  To use 
the Paint Bucket Tool: 

1. Select the Paint Bucket Tool (right-click the Gradient Tool, and then click 
Paint Bucket Tool). 

 

2. Select a foreground color by clicking Set foreground color; then select  
a color. 

         

3. Click on the object or region you wish to color. 
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Adding Text to an Image 

To add text to an image: 

1. Click the Horizontal Type Tool. 

 

2. Click and drag to draw a rectangle around the area in which you wish the 
text to appear. 
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3. When the cursor appears in the text area, enter the text.  On the properties 
bar for the Text Tool, you can change many of the text’s properties: 

 

 

 Photoshop, Fireworks, GIMP, and More: Images for the Web 
August 2009  Page 16 of 21 



The Clone Stamp Tool 

The Clone Stamp tool ( ) creates a duplicate (a clone) of part of the image you 
select.  You can then place the cloned part of the image over another image or 
over a different part of the same image. You can also clone part of one layer that 
lies over another layer. Each stroke of the tool paints on more of the sample.   
The Clone Stamp tool is useful for duplicating an object or removing a defect in 
an image. 

To use the Clone Stamp tool, set a sampling point on the area you want to copy 
to another area. Then, click and drag the mouse to apply that section onto the 
new area. 

Because you can use any brush tip with the Clone Stamp tool, you have a lot of 
control over the size of the area you clone. You can also use opacity and flow 
settings in the options bar to finesse the way you apply the cloned area. You can 
sample from one image and apply the clone in another image, as long as both 
images are in the same color mode. 

In the following example, we added an extra flower to the vine by sampling the 
flower and then cloning it below. 

 
 

Altering an Image with the Clone Stamp Tool 
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Saving Images in Photoshop 
The best choice for saving images in Photoshop is Save for Web & Devices. 

1. On the File menu, click Save for Web & Devices. 

 

2. Select 4-up to display four different versions of your picture.   

 

3. Pick the one that is the most optimized — the version that is smallest in 
size but still looks clean — for your desired use.  In this case, since they all 
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look approximately the same, we pick the one that has the smallest file 
size.   

 

4. Then, click Save. 

 Photoshop, Fireworks, GIMP, and More: Images for the Web 
August 2009  Page 19 of 21 



 

5. In the Save Optimized As field, choose the desired location, and then 
click Save. 

 

6. If you are replacing an existing file, in the Replace Files field, click 
Replace. 

 

7. On the File menu, click Close. 
 

 Photoshop, Fireworks, GIMP, and More: Images for the Web 
August 2009  Page 20 of 21 



Resources 

• Obtaining Photoshop 
Official Stanford Use: 
http://fingate.stanford.edu/staff/buypaying/smartmart.html 

Personal Use: 
http://www.stanford.edu/group/bookstore/ 

• Many image repositories exist.  Some great places you can go to obtain 
images are: 
http://commons.wikimedia.org/ 

http://www.stanford.edu/group/identity/ 

https://techcommons.stanford.edu/topics/web-development/photo-
archive 

http://www.flickr.com/photos/tags/stanford/clusters/california-
paloalto-university/ 
http://www.barrysclipart.com/ 

http://directory.google.com/Top/Computers/Graphics/Clip_Art/ 

http://directory.google.com/Top/Computers/Graphics/Clip_Art/ 
Public_Domain/ 

• For instructor-led courses offered by Technology Training Services, 
including more advanced Photoshop classes, go to 
http://techtraining.stanford.edu/courses.html 

• For personalized, one-on-one training offered by Technology Training 
Services on Photoshop, Fireworks, GIMP, and other topics, go to 
http://tba.stanford.edu/ 
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