File Menu

From VISTA LAB WIKI

Jump to: navigation, search

The mrVista File menu offers options for loading and saving data, saving GUI preferences for the view, exporting an image showing the current state of the view window, selecting a reference anatomy file, and quitting the program.

This menu is created by the function filesMenu.

[edit] Menu Options

  • Reload Anatomies: (Callback: loadAnat )
  • Select Volume Anatomy: Select the reference (or "volume") anatomy for this session. (Callback: setVAnatomyPath )
  • Report Volume Anatomy: Report the currently-selected volume anatomy path in a message box. (Callback: getVAnatomyPath )
  • CorAnal Submenu:
  • Parameter Map Submenu:
  • ROI Submenu:
  • Retinotopy Model Submenu:
  • Save Preferences: Save the GUI preferences for this window. The next time you open a window of the same view type (e.g., Inplane), the window will be in the same position, point to the same data type and scan, and if any maps or coherence analyses are loaded, they will be automatically reloaded. (Callback: savePrefs; )
  • Write Tiff Image: Save a TIFF format image of the current axes. (In a 3-view window, this will only save one of the 3 axes). (Callback: writeTiffImage; )
  • Publish Figure: This option is specific to 3-view windows; it saves an image file showing the 3 axes currently being viewed. (Callback: publish3View; )
  • Save mrSESSION: Save the current state of the mrSESSION variable. (Callback: saveSession; )
  • (Re-)create Readme.txt: Create a text file, 'Readme.txt', in the session directory which contains information on the original data (inplanes and functionals) which were initialized to produce this session. Includes some annotation for each scan. Previously, this was a mandatory step called during mrInitRet, but it has since become optional, and is not much used. (Callback: mrCreateReadme; )
  • Quit: Close the current window. If this is the only window open, exit mrVista, clearing the global variables (mrSESSION, INPLANE, VOLUME, etc) from the memory.
Personal tools