View Menu

From VISTA LAB WIKI

Jump to: navigation, search

The mrVista View menu contains options for setting what functional data (if any) are viewed on top of the anatomical images.s

This menu is created by the function viewMenu .

Contents

[edit] Menu Options

[edit] Anatomy and ROIs (no overlay)

This view hides any data overlays, and shows only the underlay image. If the ROI view options are set to show ROIs, they will also be drawn over the underlay.

[edit] Coherence Map

This option shows coherence data from a traveling wave analysis. The data are stored in the INPLANE{#}.co{} field (which is cell of data matrices for each scan) of the global INPLANE{} variable. If this field is empty (a traveling wave analysis ("corAnal") has not been computed using the Analysis menu), selecting this option will have no effect.

The minimum coherence threshold to use when displaying data is determined by the 'cothresh' slider, to the upper right side of the window, below the data types popup.

While originally specific to traveling wave analyses, the .co field and cothresh slider have been co-opted by other analyses, to provide multiple options for thresholding data. For instance, if you compute a contrast map (which by default reflects the -log(p) value of the contrast for each voxel), the absolute value of the map is normalized and mapped to the .co field. This means setting the cothresh slider will restrict voxels whose absolute value is below a certain level, letting you display both highly positive and negative contrasts. For instance, if you run a contrast (left > right visual field) for retinotopic data, and increase the cothresh to around .1, you will see populations of voxels which strongly prefer either left over right stimulation, or right over left, in different colors. This also works well with the 'Bicolor' color map option accessible in the menu Colormap | Parameter Map Mode | Bicolor. Also, the Retinotopy Model code allows you to map arbitrary fields from the model to the .co field.

[edit] Amplitude Map

This option will display amplitude data from a traveling wave analysis. The data are stored in the INPLANE{#}.amp{} field. If a traveling wave analysis ("corAnal") has not been computed using the Analysis menu, selecting this option will have no effect.

The amplitude reflects the amplitude of the best fitting sinusoid in the traveling wave analyses. It is generally used only in viewing traveling-wave data. In Amplitude mode, the 'mapWinMin' and 'mapWinMax' sliders on the right side of the window will restrict voxels according to amplitude. In all other modes, they refer to the more general .map{} (parameter map) field.


[edit] Phase Map

This option will display phase data from a traveling wave analysis. The data are stored in the INPLANE{#}.ph{} field. If this field is empty (a traveling wave analysis ("corAnal") has not been computed using the Analysis menu), selecting this option will have no effect.

For Traveling Wave experiments, the phase field reflects the phase of the best-fitting sinusoid for each voxel. The essence of a traveling wave analysis is that this value tends to vary smoothly from voxel to voxel. So, if you've performed a mapping experiment like a retinotopy experiment, a way to assess if this works is if the colors vary smoothly. (You will probably want to restrict to significant voxels; a cothresh value of around .20 is usually significant and restricts to good voxels, although it's good to test a range of values, and examine things like the level of noise outside the brain, to determine a good threshold for each data set.)

Note that the phase value is expressed in radians and reflects the zero-point crossing of the best-fitting sinusoid, relative to the start of each cycle. This is distinct from radians of visual angle, and to relate this value to the parameter being mapped by an experiment requires consideration of what's being displayed in the experiment over the course of one cycle. There are some tools available to help with this, in the menu Colormap | Set Retinotopy Params..., which will be described shortly.

Like the .co{} field, the .ph{} field is also used for other analyses. The Retinotopy model data can project any field into a ph map. Some of the maps produced by MultiVoxelUI analyses may also project parameters such as voxel reliability into this field, to allow for thresholding by multiple criteria.

[edit] Phase Projected ...

Phase-projected amplitude and coherence maps show the amplitude and coherence, respectively, of a sine wave with the stimulus frequency and a single, pre-set reference phase. The first time you call one of these options, you will be asked to set the reference frames in radians (0 radians = sine wave starts at the beginning of each cycle; pi radians = sine wave starts halfway through the cycle).

This approach is useful for ABAB-alternating experimental designs. For instance, suppose you ran an MT localizer which alternated a block of a motion stimulus with a block of a static stimulus, several times. Setting the reference frame to 0 radians would be a good choice for this case. Voxels which responded well during the motion stimulus (the first half of a cycle) would cohere well with the sine wave, and have a high phase-projected coherence (and, possibly, amplitude, although that's a distinct question). They would appear red-yellow in the maps, by default. Voxels which preferred the static blocks would have a negative correlation with the sine wave predictor, because the predictor is rising during the first half of the cycle, while the voxels' responses would be rising during the second half. The phase projected coherence and amplitude would then be negative, and appear blue-cyan in the default color map.

These callbacks invoke the code computeProjectedMap .

[edit] Mean Map

This option views the mean intensity map (mean over time) of the functionals for each scan. This value is stored in the INPLANE{#}.map{} field. Note that this option specifically looks for the mean map, though other maps may also be stored in the .map field. If a file 'meanMap.mat' is not found in the data directory for the selected data type (e.g., Inplane/Original/meanMap.mat), it will automatically try to compute this map for all scans. You can compute it ahead of time, or only for certain scans, under the Analysis menu.

In viewing traveling wave data, it is sometimes good to load this map as well, and restrict it using the mapWinMin slider, such that the lowest intensities are not considered. This will add an extra criterion for data display / ROI selection which will remove voxels which have a low signal.

[edit] Laminar Distance Map

This option views data reflecting the mean distance along gray matter, and is part of David Ress' laminar analysis tools. [It could use more explanation.]

[edit] Residual Std. Map

This option views the residual standard deviation from a traveling wave analysis. This value is stored in the INPLANE{#}.map{} field. It may be computed in the Analysis menu under Traveling Wave options. If no map is found (name 'resStdMap.mat' in the current data type folder), will produce a warning and do nothing.

The residual std. deviation provides a measure of the remaining variance after fitting with a sinusoid.

[edit] Parameter map

This option views whatever data are contained in the INPLANE{#}.map{} field for the current scan. If no map is loaded, this option does nothing. All GLM contrast maps, and generalized maps (like the mean map or the spatial gradient map) are stored in the .map field.

Personal tools